ultrasn0w 1.2.1 Just Released – A Simple Tool to Unlock iPhones Running iOS 4.3.1

After weeks of waiting, the Dev Team finally released an update to its iPhone unlock tool, ultrasn0w. The new version, dubbed ultrasn0w 1.2.1, is compatible with iPhones running 4.3.1, and will allow you to keep your baseband unlock. The new version will not unlock any new baseband, but users who already have an unlocked iPhone running an older version of iOS will now be able to update to iOS 4.3.1, as long as their iPhone 3GS or iPhone 4 uses one of the following basebands:
  • iPhone 4: 01.59.00
  • iPhone 3GS: 04.26.08 / 05.11.07 / 05.12.01 / 05.13.04 / 06.15.00
More details directly from the Dev Team blog:
This isn’t a new unlock! It’s to allow those who are already using ultrasn0w to use FW 4.3.1. It also fixes the signal bar issue for those who aren’t using the unlock but retain an older baseband intentionally. AFTER INSTALLING ULTRASN0W 1.2.1, PLEASE REBOOT YOUR iPHONE using the normal “slide to power off” swipe. T-Mobile users in the USA also should disable 3G mode in Settings->General->Network.
Before installing ultrasn0w, use PwnageTool to upgrade your device to iOS 4.3.1 – PwnageTool will allow you to keep your current baseband. Once your device is updated to iOS 4.3.1, fire up Cydia, and add the following repository: http://repo666.ultrasn0w.com. After the tool is installed, reboot your device (home+sleep buttons), and you’re done. Also worth noting, you might want to save your SHSH blobs via a tool such as TinyUmbrella first before running the tool, just in case.